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Purpose of CSS M‘“”?{?;’b

Style language for HTML and XML
Separates content from formatting
Cross-platform compatibility
o Viewers: Internet Explorer / Firefox / Opera / Safari / Outlook /...
o Platforms: Windows / UNIX / Linux / Mac / ...
o Data: HTML / XHTML / XML / ...
o Languages: English / Hebrew / Japanese / ...
Intended for control of overall appearance
Not intended for pixel-level precision
o Will not replace FrameMaker, Word, and PDF for printing books
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Relevance for Technical Writers M‘“’?{r‘;’b

m Most technical writers generate HTML

m HTML authoring tools require or generate CSS
0 Dreamweaver

WebWorks ePublisher

RoboHelp

Flare

Word

O Outlook

m XML-based workflows output to HTML + CSS

O o oo
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HTML Provides Structural Markup

<html>
<head>
<title>Peeling Potatoes</title>
</head>
<body>
<hl>How to Peel a Potato</hl>
<img src="PotatoProcedure.gif">
<p>To peel a potato:</p>
<ol>
<li>Grasp a potato in your left hand.</1li>
<1li>Hold the peeler in your right hand.</1li>

peel from the potato and expose the white.</li>
</ol>

</body>

</html>

Mlmond
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<li>Moving the peeler in short, quick motions, scrape the
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Default Formatting Almgs,

How to Peel a Potato

To peel a potato:

1. Grasp a potato in vour left hand.
2. Hold the peeler in your right hand.
3. Moving the peeler in short, quick motions, scrape the peel from the potato and expose the white.

=

Formatted Appearance

Mlmond
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To peel a potato:

a. Grasp a potato in your left hand.
b. Hold the peeler in your right hand.

c. Moving the peeler in short, quick
motions, scrape the peel from the
potato and expose the white.
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font-family:Verdana,
Arial, Helvetica, sans-

margin-left:30px;

margin-bottom:9px; }
}
ol
hl { {
color:#FF9933; alpha;

margin-bottom:24px;
margin-top:6px;

} }

img { 1i {
background-color:#FF9933;
float:right; }
width:110px;
padding:10px;

CSS Code Implementing the Format

body { margin-top:0px;
margin-right:20px;

2 border-style:double;
serif; border-color:#117788;
border-width:3px;

list-style-
position:outside;

M'm?{r‘fb

list-style-type:lower-

margin-bottom: 6px;
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CSS Levels

m CSS1
o 1996, 1999
O W3C Recommendation
m CSS2.1
o 2004
O W3C Candidate Recommendation
m CSS3
O Under development
m Each level includes the previous levels
O Adds new features

M'm?{r‘fb
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Features Introduced by CSS Levels

m CSS1
0O Basic visual formatting
m CSS2
0O Absolute positioning
O RTL text
o Selector logic / XML support
0O Audio properties
m CSS3
0 Media support
Interactivity
Selector logic
Snaking columns, rounded borders, etc.

O oo

M'm?{r‘fb
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Browser Support - Vendor Quotes

m MSIE 6
o "Full CSS1"
m MSIE 7
O "Improved support for CSS2.1"
m Firefox 1.5
O "Improved support for CSS2 and CSS3"
m Safari

O "The most complete implementation of the CSS
specification™
O Provides a list of supported CSS features

M'm?{r‘fb
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Attaching Styles to an HTML Document M‘“’?{r‘;’b

m Inline

<div style="color:red; font-size:18px;">

Style Sheet Language m <Style> element

<style>
body {color: black; font-size:12px;}
div.bigblue {color:blue; font-size:18px;}
</style>

m Linked style sheet

<link rel="stylesheet" type="text/css"
href="potato.css">
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Example of Attaching Styles M‘“’?{f‘;’b Resulting Display M‘“’?{f‘;’b

<html>
<head>
<title>Peeling Potatoes</title>
<link rel="stylesheet" type="text/css" href="potato.css">

<style>
1i {color:#117788;} To peel a potato:
</style>
</head> a. Grasp a potato in your left hand.
<body> . . b. Hold the peeler in your right hand.
<hl style="text-align:right; ">How to Peel a Potato</hl>
<img src="PotatoProcedure.gif"> c. Moving the peeler in short, quick motions,
<p>To peel a potato:</p> scrape the peel from the potato and expose
<ol> the white.
<li>Grasp a potato in your left hand.</1li>
<li>Hold the peeler in your right hand.</1li>

<li>Moving the peeler in short, quick motions, scrape the peel
from the potato and expose the white.</li>

</ol>
</body>
</html>
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Selectors AVmes,

<p id="me" class="red">A paragraph.</p>

m Element selector
p {font-size:12px;}

m Class selector
.red {color:red;}
p.red {color:red;}

m |D selector
#me {font-variant:small-caps;}
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Contextual Selectors A\mgs,

<div class="note">
<p><img src="NoteIcon.png">
A paragraph
</p>
</div>

img {background-color:yellow;}

| Matches any <img> |

div.note p img {background-color:yellow;}

Matches only an <img> nested within a <p>
nested within a div having class="note"
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Grouping Rlimend.

hl {font-family:Arial;}
hl {color:blue;}
h2 {font-family:Arial;}
h2 {color:blue;}

hl, h2 {

font-family:Arial;
color:blue;

Equivalent representations

19
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Examples of CSS1 Properties [\imend.
color padding
font-family border-color
font-size border-style
font-style border-width
font-weight margin
text-indent
direction width

height
background-color
background-image display
background-repeat float

white-space

20
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CSS Box Model

Ipadding

'I;his is an object on an HTML pagﬁ
width
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Margins Collapse ™ b

m 1st paragraph: | |

margin-bottom:18px; 1

m 2nd paragraph:
margin-top:6px;
m Result:
18px between the paragraphs

Equivalent option in Microsoft Word:
Tools > Options > Compatibility > Don't use HTML paragraph auto spacing
- If selected, 24px between paragraphs

- If not selected, 18px between paragraphs (recommended)
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Pseudo-Classes and Elements

a:link {color:#3366FF;}
athover {color:#FF6633;}
aszactive {color:#FF0000;}
a:visited {color:#336699;}

Click here for more information

p:first-letter {font-size:200%; float:left;}

Drop capital

M'm?{r‘fb
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Cascading: Resolving Rule Conflicts

M'm?{r‘fb

1. Multiple style sheets

o Author > User > Browser default
2. Multiple rules

o More specific selector > Less specific selector
3. Last rule wins

| Last rule

Body {font-family:Verdana;}
Body {font-family:Arial;}

Body H1 {font-family:Verdana;}
H1 {font-family:Arial;}

More specific selector

24
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Example of Conflicting Rules M‘“’?{f‘;’b Best Practices for Style Sheet Design M‘“’?{r‘;’b
<p class="Note">This is a note.</p> m Use inheritance

body {font-family:Arial,sans-serif;font-size:12px;}
p {font-size:10pt; font-weight:normal; color:black;} hl {font-size:20px;}
p.Note {font-size:12pt; font-weight:bold;} p {}

.Note {font-weight:normal; font-style:italic;} a Or define each sndeindependenﬂy

hl {font-family:Arial,sans-serif;font-size:20px;}

Result: p {font-family:Arial,sans-serif;font-size:12px;}
12pt (more specific selector) m Avoid mixing the two styles
bold (more specific selector) m Add comments

/* Default style */

italic (no conflicting rule)
body {font-family:Arial, sans-serif;font-size:12px;}

black (no conflicting rule)
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CSS Editors A\mgs,

m NewsGator TopStyle
m Westciv StyleMaster
m Adobe Dreamweaver
m Notepad

m Help authoring tools

Creating a Style Sheet

opyright © 2008 AlmondWeb Ltd. All rights reserved. 27 28
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Example: WebWorks Style Designer M‘“‘?{r‘;’b

Paragraph Styles WNrRrers |0ptions|

=

div.Body Text

{
border-bottom-style: none;
border-bottom-width: Opt:
border-left-style: none;
border-left-width: Opt;
border-right-style: none;
border-right-width: 0Opt;
border-top-style: none;
border-top-width: 0Opt;
color: Black;

font-family: Verdana, Arial, Helvetica, Sans-Serif;
font-size: lOpt;
font-style: normal;

font-wvariant: normal;
font-weight: normal;
margin-bottom: &pt;

WebWorks CSS Output Rimeze,

30

.ﬂ ° ‘éﬂ '@ Background _Fontproperties

- [Prototype] ;I Border

H Bullet Family: I\u’erdana,AriaI,Hel\.'etica,Sans-S;I = -
HTML Size: ICustnm jl 10 Ipt j =
Margin

Padding Style: I j T -

7% AWBullets Text

) AWGraphics Variant | =] -

ﬁ AWHeadings i

- AWNoOUtput Weight: I H@-

L AWM mherad
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H |
Troubleshooting a Style Sheet Rlimend.

m W3C CSS validator
m Style checkers built into CSS editors

W3C CSS Validator Results for file://localhost/D:\UsersiAlmondWeb\
pre2007\test wwep\cssitest wwep.css

Sorry! We found the following errors

5571 div.Procedure_Header  Value Error © cursor hand is not a cursor value © hand
5614 Procedure_Header_inner Value Error - cursor hand is not a cursor value © hand
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Conflicts between Rules A\mgs,

<p class="Note">This is a note.</p>
p {font-size:10pt; font-weight:normal; color:black;}

p.Note {font-size:12pt; font-weight:bold;}
.Note {font-weight:normal; font-style:italic;}

Result: 12pt bold italic black

32
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Incomplete Browser Support M‘“’?&‘;’b

m CSS2 defines an outline property

o Similar to border but does not occupy space in box
model

o Firefox supports
o MSIE 7 does not support

33
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Accessibility
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Imperfect Browser Support M‘“’Wé’b

m All elements are supposed to inherit from <body>
m In old browsers, table cells <td> failed to inherit
m Work-around

O In old CSS code, you are likely to see:

body, td {
font-family:Arial, Helvetica, sans-serif;

}

34
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Accessibility for Visually Impaired Users  Almsd,

Anay Ram and Yoni Erlich lost for the first ime in 10 maiches on Saturday. The israsll
duo was defeated 7-5, 4-5, 10-7 by Tomas Berdych and Dmiry Tursunov in the
semifinals of the ATP loumament in RoBierdam.

Firefox: View > Text Size > Increase

Andy Ram and Yoni Erich lost for the first time in 10
matches on Saturday. The Israell duo was defeated 7-5,
4-6, 10-7 by Tomas Berdych and Dmitry Tursunov in the
samifinals of the ATP tournament in Rotterdam.

MSIE 7: View > Text Size > Largest

Any Ram and Yoni Erlich 131 for e first ime in 10 matches on Saturday. The lsrael
duo was Selealed 7-5, 4-5, 10-7 by Tomnas Berdych and Dmilry Tursunoy in the
semifinals of e ATP lownament in Rofterdam
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CSS Defines Fixed Font Size in Pixels M’“’Wé’b Solution: Define Relative Font Size M’“’Wé’b
<span class="lead"> <span class="lead">
...<p>Andy Ram and Yoni Erlich ...</p>... .. .<p>Andy Ram and Yoni Erlich ...</p>...
</span> </span>
.lead { .lead {
font-family: Arial, sans-serif; font-family: Arial, sans-serif;
font-size: 12px; font-size: 0.75em;
font-weight: normal; font-weight: normal;
line-height: 140%; line-height: 140%;
} }
* In MSIE 7, enlarging the base font does not affect fixed font sizes e lem = font size of parent element
« In Firefox, enlarging the base font scales all font sizes * Enlarging the parent size enlarges the size of an em
37 38
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Effect of Relative Size Definition Almend. Web

Andy Ram and Yoni Erlich lost for the first ime in 10 matches on Saturcay, The israed
duo was defeated 7-5, 4-5, 10-7 by Tomas Berdych and Dmilry Tursuno in e
semifinals of the ATP loumament in RoBierdam.

Firefox: View > Text Size > Increase

Andy Ram and Yoni Erlich lost for the first time in 10 Other TeCh n i Cal I SSUGS

matches on Saturday. The Israell duo was defeated 7-5.
4-8, 10-7 by Tomas Berdych and Dmitry Tursunov in the
samifinals of the ATP tournament in Rotterdam.

MSIE 7: View > Text Size > Largest

Andy Ram and Yoni Erich lost for the first time
in 10 matches on Saturday. The Israeli duo was
defeated 7-5, 4-6, 10-7 by Tomas Berdych and
Dmitry Tursunov in the semifinals of the ATP
tournament in Rotterdam.
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Scripting Support for CSS Aimsed,

m When a user clicks a button, link to an alternative
style sheet
O Support multiple browsers (obsolete)
O Accessibility
m Modify inline styles
o Display hidden sections of a page
o display:none -> display:block

41
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Browser-Specific CSS Extensions M‘“’?&‘;’b

) Behaviors are a
= Scenario Microsoft extension
o A user fills in an HTML form offline

o The user saves the HTML page

m  Default:
o0 The page is saved without the form data
o The user's entries are lost

m  Add a saveSnapshot behavior to the CSS code:
<style>
.sSnapshot
{behavior:url (#default#savesnapshot);}
</style>
0O The page is saved with the form data
o The user can re-open the page and submit the form

Internet Explorer only!
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Unsupported Features Aimsed,

m Tab stops

0O By design, HTML collapses tabs to space characters
m Conditional logic

o Format the second <p> within a <div> in red

o If the page contains a Warning heading, format the
next paragraph in red

CSS2 and CSS3 provide partial solutions
Browsers do not yet fully support

O 0O
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Where to Learn More
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World Wide Web Consortium Klimend.

http://www.w3.0rg/Style/CSS

Specifications

Definitive Reference

Revision history

Links to browsers and tools supporting CSS
Links to CSS books and tutorials
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W3 Schools A\mgs,

http://www.w3schools.com/css

m CSS tutorial
O Mostly CSS1

m Practical reference
m Interactive examples
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Outline AV,

What is CSS?

Style Sheet Language
Creating a Style Sheet
Accessibility

Other Technical Issues
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Where to Learn More
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Secrets of CSS: Using

Cascading Style Sheets

David Shaked (Wernick)
AlmondWeb Ltd.
02-5712246
david@almondweb.com
http://www.almondweb.com
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